On Monday, 12 March 2007 14:24, Cedric Le Goater wrote: > Oleg Nesterov wrote: > > On 03/12, Rafael J. Wysocki wrote: > >> On Monday, 12 March 2007 09:14, Pavel Machek wrote: > >>> Can we get better name for this function? > >> Well, I took the name from the Oleg's message. Can you please suggest > >> something? > > > > Well, kthread_should_stop_check_freeze() is really awful, I agree :) > > We need something better, but I can't suggest anything. > > not much better, but what about kthread_should_stop_or_freeze() ?
IMO this suggests that the thread will either stop or freeze itself, but the freezing part is not unconditional. I was thinking of kthread_should_stop_freezable() . Greetings, Rafael - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/