Ping?_
> -----Original Message----- > From: linux-kernel-ow...@vger.kernel.org > [mailto:linux-kernel-ow...@vger.kernel.org] On Behalf Of 岩松信洋 / > IWAMATSU,NOBUHIRO > Sent: Monday, December 05, 2016 10:47 AM > To: Kees Cook > Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; > cti.systems-productivity-manager...@hitachi.com > Subject: RE: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances > > Hi, Kees. > > > -----Original Message----- > > From: keesc...@google.com [mailto:keesc...@google.com] On Behalf Of > > Kees Cook > > Sent: Saturday, November 12, 2016 7:24 AM > > To: 岩松信洋 / IWAMATSU,NOBUHIRO > > Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; > > cti.systems-productivity-manager...@hitachi.com > > Subject: Re: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg > > instances > > > > On Tue, Oct 18, 2016 at 12:13 AM, Nobuhiro Iwamatsu > > <nobuhiro.iwamatsu...@hitachi.com> wrote: > > > The following series implements multiple pmsg. This feature allows > > > userspace program to control individual content aging or priority. > > > > > > If a pstore backend module(e.g. ramoops) requires the multiple pmsg > > > instances when registering itself to pstore, multiple /dev/pmsg[ID] > > > are created. Writes to each /dev/pmsg[ID] are isolated each other. > > > After reboot, the contents are available in > > /sys/fs/pstore/pmsg-[backend]-[ID]. > > > > > > In addition, we add multiple pmsg support for ramoops. We can > > > specify multiple pmsg area size by its module parameter as follows. > > > > > > pmsg_size=0x1000,0x2000,... > > > > > > I did check the operation of this feature on CycloneV (socfpga) > > > Helio > > board. > > > > > > v3: > > > Rebase to v4.8. > > > Split patch. > > > merged device_create(). > > > Remove Blank lines. > > > Update documentiation of DT binding. > > > Update parsing function of ramoops_pmsg_size, add NULL termination. > > > Update module parameters for pmsg_size list. > > > > Thanks for this v3! Sorry for the delay, I should be able to review > > this shortly. > > Thank you. > I will wait for your review. > > > > > -Kees > > > > Best regards, > Nobuhiro > > > > > > > Hiraku Toyooka (2): > > > pstore: support multiple pmsg instances > > > selftests/pstore: add testcases for multiple pmsg instances > > > > > > Nobuhiro Iwamatsu (6): > > > pstore: Replace four kzalloc() calls by kcalloc() in > > ramoops_init_przs() > > > pstore: Change parameter of ramoops_free_przs() > > > ramoops: Add __ramoops_init_prz() as generic function > > > pstore: Rename 'przs' to 'dprzs' in struct ramoops_context > > > ramoops: Rename ramoops_init_prz() to ramoops_init_dprzs() > > > ramoops: support multiple pmsg instances > > > > > > .../bindings/reserved-memory/ramoops.txt | 6 +- > > > Documentation/ramoops.txt | 22 ++ > > > fs/pstore/pmsg.c | 23 +- > > > fs/pstore/ram.c | 344 > > ++++++++++++++++----- > > > include/linux/pstore.h | 1 + > > > include/linux/pstore_ram.h | 8 +- > > > tools/testing/selftests/pstore/common_tests | 21 +- > > > .../selftests/pstore/pstore_post_reboot_tests | 27 +- > > > tools/testing/selftests/pstore/pstore_tests | 14 +- > > > 9 files changed, 360 insertions(+), 106 deletions(-) > > > > > > -- > > > 2.9.3 > > > > > > > > > > > > > > -- > > Kees Cook > > Nexus Security