On Sat, Dec 10, 2016 at 09:36:29PM +0800, Boqun Feng wrote: > On Fri, Dec 09, 2016 at 08:28:05PM -0800, Paul E. McKenney wrote: > > On Sat, Dec 10, 2016 at 08:45:38AM +0800, Boqun Feng wrote: > > > On Fri, Dec 09, 2016 at 03:49:45PM -0800, Paul E. McKenney wrote: > > > > On Fri, Dec 09, 2016 at 04:48:22PM +0800, Boqun Feng wrote: > > > > > Hi Paul, > > > > > > > > > > While reading the discussion at: > > > > > > > > > > https://marc.info/?l=linux-kernel&m=148044253400769 > > > > > > > > This discussion was for stalls specifically, rather than for routine > > > > scans of the bitmasks. > > > > > > > > But it does look to save some code, so worth looking into. > > > > > > > > > I figured we might use this fact to save some extra checks in RCU > > > > > core code, > > > > > currently we iterate over all the possible CPUs on a leaf node, check > > > > > whether > > > > > they were masked in a certain mask and do something. However, given > > > > > the fact > > > > > that the masks on a leaf node should always be sparse than the > > > > > corresponding > > > > > part of cpu_possible_mask, we'd better iterate over all bits in a > > > > > mask and > > > > > check whether the corresponding CPU is possible or not. > > > > > > > > > > So I made this RFC, I did a simple build/boot/rcutorture test on my > > > > > box with > > > > > SMP=4, nothing bad happens. Currently I'm waiting for the 0day and > > > > > trying to > > > > > test this one a bigger system, in the meanwhile, looking forwards to > > > > > any > > > > > comment and suggestion. > > > > > > > > > > So thoughts? > > > > > > > > By analogy with for_each_cpu() and for_each_possible_cpu(), the name > > > > should instead be for_each_leaf_node_cpu(), the tradition of excessively > > > > long names in RCU notwithstanding. ;-) > > > > > > > > > > Make sense ;-) > > > > > > I think it's more appropriate to call it for_each_leaf_node_mask_cpu(), > > > because we don't iterate all cpus of a leaf node. The word "possible" > > > could be dropped because obviously we won't iterate over "impossible" > > > cpus in a leaf node ;-) > > > > C'mon, Boqun! The for_each_leaf_node_cpu() is not only consistent > > with the for_each_cpu() family, it is shorter! ;-) > > Sure ;-) But for_each_leaf_node_cpu() seems like an operation that > iterates over _all_ cpus in a leaf node, but I actually implement it as > an operation that iterates only the _masked_ cpus. So I feel like word > "mask" better be added in the name.
Although that is a fair point, the same can be said of for_each_cpu(). Which people seem to be able to use without undue pain. > If we call it for_each_leaf_node_cpu(rnp, mask,...), we will rely on the > hope that readers could figure it out what the primitive actually does > by the indication of the parameter @mask. > > I like shorter names too, but not sure whether putting "mask" in the > name is better. After all, naming is one of the most difficult > challenges in programming ;-) The two most difficult challenges in programming are the last two hard things that the person speaking worked on. ;-) Consistency is more important than the stand-alone understanding of this particular name. You can always add a comment pointing out that it follows for_each_cpu(). Thanx, Paul > Regards, > Boqun > > > Thanx, Paul > > > > > Will modify that in next version. > > > > > > Regards, > > > Boqun > > > > > > > Thanx, Paul > > > > > > > >