> - if (of_get_property(pdev->dev.of_node, > - "little-endian", NULL)) > + if (of_property_read_bool(pdev->dev.of_node, "little- > endian")) > priv->is_little_endian = true; > else > priv->is_little_endian = false; >
Perhaps, while changing this, that'd be better as priv->is_little_endian = of_property_read_bool(...); Obviously that would've worked before, but now it'd be even easier to understand, it seems. johannes