On Tue, 6 Feb 2007 14:05:39 +0300 Oleg Nesterov <[EMAIL PROTECTED]> wrote:
> On 02/06, S?bastien Dugu? wrote: > > > > @@ -970,8 +969,14 @@ static long aio_setup_sigevent(struct ai > > rcu_read_lock(); > > target = sigevent_find_task(&event); > > > > - if (unlikely(!target)) > > + if (unlikely(!target)) { > > + /* > > + * Revert notify to SIGEV_NONE so that really_put_req() > > + * knows that no ref has been taken on a task. > > + */ > > + notify->notify = SIGEV_NONE; > > goto out_unlock; > > + } > > Very minor nit, feel free to ignore. > > Isn't it better to move "notify->* = event.*;" down, when we know that > target != NULL. Imho, a bit easier to follow. This way we don't need to > reset notify->notify = SIGEV_NONE. > > aio_setup_sigevent() relies on the fact that ->notify = SIGEV_NONE on > entry anyway. Yep, right, it will make things cleaner. Thanks, Sébastien. - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/