2016-01-22 05:12+0000, Wu, Feng:
>> From: Radim Krčmář [mailto:rkrc...@redhat.com]
>> 2016-01-20 09:42+0800, Feng Wu:
>> > +{
>> > +  u32 mod;
>> > +  int i, idx = 0;
>> > +
>> > +  mod = vector % dest_vcpus;
>> > +
>> > +  for (i = 0; i <= mod; i++) {
>> > +          idx = find_next_bit(bitmap, bitmap_size, idx) + 1;
>> 
>> I'd remove this "+ 1".  Current users don't check for errors and always
>> do "- 1".  The new error value could be 'idx = bitmap_size', with u32 as
>> return type.
>> 
> 
> Does the following code look good to you:
> 
>         u32 mod;
>         int i, idx = -1;
> 
>         mod = vector % dest_vcpus;
> 
>         for (i = 0; i <= mod; i++) {
>                 idx = find_next_bit(bitmap, bitmap_size, idx + 1);
>                 BUG_ON(idx == bitmap_size);
>         }
> 
>         return idx;

It's ok, thanks.

Reply via email to