Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangt...@163.com>
---
 fs/lockd/svc.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/fs/lockd/svc.c b/fs/lockd/svc.c
index 44d18ad..b4006c72 100644
--- a/fs/lockd/svc.c
+++ b/fs/lockd/svc.c
@@ -94,8 +94,7 @@ static unsigned long get_lockd_grace_period(void)
 
 static void grace_ender(struct work_struct *grace)
 {
-       struct delayed_work *dwork = container_of(grace, struct delayed_work,
-                                                 work);
+       struct delayed_work *dwork = to_delayed_work(grace);
        struct lockd_net *ln = container_of(dwork, struct lockd_net,
                                            grace_period_end);
 
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to