On Thu 03-12-15 14:27:50, Johannes Weiner wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> > 
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
> 
> You asked the same thing when reviewing the patch for the first
> time. :-) I think it's time to add a comment.

Ohh, I completely forgot about mem_cgroup_uncharge doing
uncharge_list(&page->lru)

> >From e8ba3f31bb43ed4091b997b6ee8857dc8bbcd349 Mon Sep 17 00:00:00 2001
> From: Johannes Weiner <han...@cmpxchg.org>
> Date: Thu, 3 Dec 2015 14:21:45 -0500
> Subject: [PATCH] mm: memcontrol: clarify the uncharge_list() loop
> 
> uncharge_list() does an unusual list walk because the function can
> take regular lists with dedicated list_heads as well as singleton
> lists where a single page is passed via its page->lru list node.
> 
> This can sometimes lead to confusion, as well as suggestions to
> replace the loop with a list_for_each_entry(), which wouldn't work.

Yes, this is helpful.
 
> Signed-off-by: Johannes Weiner <han...@cmpxchg.org>

Acked-by: Michal Hocko <mho...@suse.com>

> ---
>  mm/memcontrol.c | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> index 9acfb16..f7ee1c0 100644
> --- a/mm/memcontrol.c
> +++ b/mm/memcontrol.c
> @@ -5422,6 +5422,10 @@ static void uncharge_list(struct list_head *page_list)
>       struct list_head *next;
>       struct page *page;
>  
> +     /*
> +      * Note that the list can be a single page->lru; hence the
> +      * do-while loop instead of a simple list_for_each_entry().
> +      */
>       next = page_list->next;
>       do {
>               unsigned int nr_pages = 1;
> -- 
> 2.6.3

-- 
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to