On Sat, 9 Dec 2006, Pekka Enberg wrote: > On 12/9/06, Robert P. J. Day <[EMAIL PROTECTED]> wrote: > > @@ -705,7 +705,7 @@ static int uss720_probe(struct usb_inter > > /* > > * Allocate parport interface > > */ > > - if (!(priv = kcalloc(sizeof(struct parport_uss720_private), 1, > > GFP_KERNEL))) { > > + if (!(priv = kcalloc(1, sizeof(struct parport_uss720_private), > > GFP_KERNEL))) { > > This one should be kzalloc > > You really ought to send these cleanups to [EMAIL PROTECTED] with LKML > cc'd to get them merged.
good point, and argh. good point in that any further patches that are primarily stylistic and/or aesthetic like the above will be sent to akpm, and CC'ed to list. argh, in that i've already mentioned that, following the guidelines in "SubmittingPatches", i prefer that each of my patches have one logical purpose. once the order of the kcalloc() args is corrected, that would be followed by a single subsequent patch that did the kcalloc->kzalloc transformation all at once. if that's *not* the way folks on this list wish to see patches, then that advice should be removed from "SubmittingPatches." as captain hollister once said to dave lister, "choose." rday - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/