* Horst H. von Brand <[EMAIL PROTECTED]> wrote:

> Why not just:
> 
>     WARN_ON(debug_locks_off())
> 
> here? Would give a more readable message too, IMHO.

debug_locks_off() has a side-effect, and in general we dont like to put 
stuff with side-effects witin WARN_ON().

        Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to