On Fri, 2025-02-28 at 10:58 +0000, André Draszik wrote:
> Hi Linus,
> 
> Thanks for you review!
> 
> On Fri, 2025-02-28 at 08:10 +0100, Linus Walleij wrote:
> > Hi André,
> > 
> > thanks for your patch!
> > 
> > mostly looks fine, given the MFD design is accepted.
> > Nitpicks below:
> > 
> > On Wed, Feb 26, 2025 at 6:51 PM André Draszik <andre.dras...@linaro.org> 
> > wrote:
> > 
> > > +static irqreturn_t max77759_gpio_irqhandler(int irq, void *data)
> > > +{
> > > +       int handled = 0;
> > 
> > bool handled = false;
> > 
> > (...)
> > > +               for_each_set_bit(offset, &pending, MAX77759_N_GPIOS) {
> > > +                       unsigned int virq;
> > 
> > I usually just call this "irq", as it's not any more virtual than any other
> > Linux magic number, and it can confuse people working with
> > actual virtualization when we call things virtual like this.
> 
> Calling it 'irq' would shadow the first argument of this irq
> handler function, which is also and usually called irq and which
> I'd like to avoid shadowing.
> 
> Are you OK with 'subirq'? Or any other preference?

Actually, there's no real need for that variable, I'll just
drop it altogether:

                        handle_nested_irq(irq_find_mapping(gc->irq.domain,
                                                           offset));

A.


Reply via email to