On Wed, Feb 7, 2024 at 5:24 PM Kees Cook <keesc...@chromium.org> wrote: > > This allows replacements of the idioms "var += offset" and "var -= offset" > with the wrapping_inc() and wrapping_dec() helpers respectively. They > will avoid wrap-around sanitizer instrumentation. > > Add to the selftests to validate behavior and lack of side-effects.
I would expect inc/dec to add/subtract 1. So, to me the terminology is confusing. The list of the C/C++ operators on Wikipedia describes above as += Assignment by sum -= Assignment by difference Hence the proposal is to have wrapping_sum() wrapping_diff() -- With Best Regards, Andy Shevchenko