On Mon, Feb 05, 2024 at 02:44:14PM -0800, Kees Cook wrote: > On Mon, Feb 05, 2024 at 12:21:45PM -0800, Eric Biggers wrote: > > On Mon, Feb 05, 2024 at 01:12:30AM -0800, Kees Cook wrote: > > > Subject: Re: [PATCH v3 2/3] overflow: Introduce add_wrap(), sub_wrap(), > > > and mul_wrap() > > > > Maybe these should be called wrapping_add, wrapping_sub, and wrapping_mul? > > Those names are more grammatically correct, and Rust chose those names too. > > Sure, that works for me. What bout the inc_wrap() and dec_wrap() names? > I assume wrapping_inc() and wrapping_dec() ? >
Yes, though I'm not sure those should exist at all. Maybe a += b should just become a = wrapping_add(a, b), instead of wrapping_inc(a, b)? wrapping_inc(a, b) isn't as self-explanatory. Likewise for wrapping_dec. - Eric