On Mon, Jan 22, 2024 at 4:36 PM Kees Cook <keesc...@chromium.org> wrote:
>
> In an effort to separate intentional arithmetic wrap-around from
> unexpected wrap-around, we need to refactor places that depend on this
> kind of math. One of the most common code patterns of this is:
>
>         VAR + value < VAR
>
> Notably, this is considered "undefined behavior" for signed and pointer
> types, which the kernel works around by using the -fno-strict-overflow
> option in the build[1] (which used to just be -fwrapv). Regardless, we
> want to get the kernel source to the position where we can meaningfully
> instrument arithmetic wrap-around conditions and catch them when they
> are unexpected, regardless of whether they are signed[2], unsigned[3],
> or pointer[4] types.
>
> Refactor open-coded wrap-around addition test to use add_would_overflow().
> This paves the way to enabling the wrap-around sanitizers in the future.
>
> Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 
> [1]
> Link: https://github.com/KSPP/linux/issues/26 [2]
> Link: https://github.com/KSPP/linux/issues/27 [3]
> Link: https://github.com/KSPP/linux/issues/344 [4]
> Cc: John Stultz <jstu...@google.com>
> Cc: Thomas Gleixner <t...@linutronix.de>
> Cc: Stephen Boyd <sb...@kernel.org>
> Signed-off-by: Kees Cook <keesc...@chromium.org>
> ---
>  kernel/time/timekeeping.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/time/timekeeping.c b/kernel/time/timekeeping.c
> index 266d02809dbb..2fc7cf16584c 100644
> --- a/kernel/time/timekeeping.c
> +++ b/kernel/time/timekeeping.c
> @@ -1984,7 +1984,7 @@ static __always_inline void 
> timekeeping_apply_adjustment(struct timekeeper *tk,
>          * Which simplifies to:
>          *      xtime_nsec -= offset
>          */
> -       if ((mult_adj > 0) && (tk->tkr_mono.mult + mult_adj < mult_adj)) {
> +       if ((mult_adj > 0) && (add_would_overflow(mult_adj, 
> tk->tkr_mono.mult))) {
>                 /* NTP adjustment caused clocksource mult overflow */
>                 WARN_ON_ONCE(1);
>                 return;

Acked-by: John Stultz <jstu...@google.com>

Reply via email to