In an effort to separate intentional arithmetic wrap-around from
unexpected wrap-around, we need to refactor places that depend on this
kind of math. One of the most common code patterns of this is:

        VAR + value < VAR

Notably, this is considered "undefined behavior" for signed and pointer
types, which the kernel works around by using the -fno-strict-overflow
option in the build[1] (which used to just be -fwrapv). Regardless, we
want to get the kernel source to the position where we can meaningfully
instrument arithmetic wrap-around conditions and catch them when they
are unexpected, regardless of whether they are signed[2], unsigned[3],
or pointer[4] types.

Refactor open-coded unsigned wrap-around addition test to use
check_add_overflow(), retaining the result for later usage (which removes
the redundant open-coded addition). This paves the way to enabling the
unsigned wrap-around sanitizer[2] in the future.

Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1]
Link: https://github.com/KSPP/linux/issues/26 [2]
Link: https://github.com/KSPP/linux/issues/27 [3]
Link: https://github.com/KSPP/linux/issues/344 [4]
Cc: Geert Uytterhoeven <ge...@linux-m68k.org>
Cc: Andrew Morton <a...@linux-foundation.org>
Cc: Arnd Bergmann <a...@arndb.de>
Cc: Liam Howlett <liam.howl...@oracle.com>
Cc: "Matthew Wilcox (Oracle)" <wi...@infradead.org>
Cc: Hugh Dickins <hu...@google.com>
Cc: linux-m...@lists.linux-m68k.org
Signed-off-by: Kees Cook <keesc...@chromium.org>
---
 arch/m68k/kernel/sys_m68k.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/arch/m68k/kernel/sys_m68k.c b/arch/m68k/kernel/sys_m68k.c
index 1af5e6082467..b2b9248f2566 100644
--- a/arch/m68k/kernel/sys_m68k.c
+++ b/arch/m68k/kernel/sys_m68k.c
@@ -391,10 +391,11 @@ sys_cacheflush (unsigned long addr, int scope, int cache, 
unsigned long len)
 
                mmap_read_lock(current->mm);
        } else {
+               unsigned long sum;
                struct vm_area_struct *vma;
 
                /* Check for overflow.  */
-               if (addr + len < addr)
+               if (check_add_overflow(addr, len, &sum))
                        goto out;
 
                /*
@@ -403,7 +404,7 @@ sys_cacheflush (unsigned long addr, int scope, int cache, 
unsigned long len)
                 */
                mmap_read_lock(current->mm);
                vma = vma_lookup(current->mm, addr);
-               if (!vma || addr + len > vma->vm_end)
+               if (!vma || sum > vma->vm_end)
                        goto out_unlock;
        }
 
-- 
2.34.1


Reply via email to