On 1/4/25 03:43, Nicolin Chen wrote:
The infrastructure of a fault object will be shared with a new vEVENTQ
object in a following change. Add a helper for a vEVENTQ allocator to
call it too.

Reorder the iommufd_ctx_get and refcount_inc, to keep them symmetrical
with the iommufd_fault_fops_release().

Since the new vEVENTQ doesn't need "response", leave the xa_init_flags
in its original location.

Reviewed-by: Kevin Tian<[email protected]>
Signed-off-by: Nicolin Chen<[email protected]>
---
  drivers/iommu/iommufd/fault.c | 48 ++++++++++++++++++++---------------
  1 file changed, 28 insertions(+), 20 deletions(-)

Reviewed-by: Lu Baolu <[email protected]>

Reply via email to