Changes in v2:
- Reorganized previous patchset and recreated patches based on 
logical change
- Rewritten logic to find certain attributes in sysfs

[Let's try again...]

This patchset primarily fixes Linaro Bug# 772
(https://bugs.linaro.org/show_bug.cgi?id=772) to remove
bashisms in all PM-QA scripts. These scripts will run on
Android, Openembedded, and Ubuntu.

Cleanups have been done to remove redundant code, improve
readability, and resolve syntax errors that were not
detected before.

Currently, the suspend and powertop test modules are disabled.
However, to maintain consistency, the format of the suspend 
and powertop scripts have been updated to be POSIX-compliant.

Next steps:

Once this patchset has been reviewed and acked, the following
steps will be taken:

1. Submit a patch to update the release tag on the pwrmgmt
test definitions to pm-qa-v0.5.0

2. Submit a patch to update the pm-qa script
(https://git.linaro.org/qa/test-definitions.git/blob/HEAD:/common/scripts/pm-qa.sh)
used to run PM-QA on Android by removing unnecessary busybox sym
links and replace suspend test module with thermal in
directory list.

3. Investigate further on why pandaboards do not like the
cpuidle_03 test case.

4. Update the PM-QA wiki with new test cases and their descriptions:
https://wiki.linaro.org/WorkingGroups/PowerManagement/Resources/TestSuite/PmQaSpecification

Comments and/or questions are highly encouraged.

Lisa Nguyen (25):
  Fix path to library files and change shebang line
  Replace double equals with one for comparison
  Remove sigtrap prefixes for traps
  Remove local keywords and uninitialized variables
  Fix syntax to get the cpu id number
  Remove thermal_try_max variable
  Switches: Add hotplug_allow_cpu0=0
  cpuhotplug: Rewrite randomize() function
  Fix the syntax to call C programs
  cpuidle: Use is_root() function in cpuidle_03
  Remove unused variables and rename some
  Remove BASH arrays
  Rewrite logic to check for sampling_rate
  suspend_functions: Check if $LOGDIR exists
  cpuhotplug: Rename 1_sanity_check files to cpuhotplug_00 files
  cpuhotplug: Rename z_sanity_check files to cpuhotplug_99
  cputopology: Add cputopology_sanity.sh
  Android: Update makefiles with new test numbers
  Use -q option for grep command
  Improve test conditions to see if a directory or file exists
  cpufreq: Remove unnecessary checks
  Test: Add sort function
  cpufreq: Check to see if scaling_available_governors is available
  cpufreq: Rewrite logic to check if powersave is supported
  Whitespace cleanup

 Switches.sh                        |    6 +-
 Test.mk                            |    2 +-
 cpufreq/cpufreq_01.sh              |    4 +-
 cpufreq/cpufreq_02.sh              |    4 +-
 cpufreq/cpufreq_03.sh              |   15 +-
 cpufreq/cpufreq_04.sh              |   16 +--
 cpufreq/cpufreq_05.sh              |  105 +++++++-------
 cpufreq/cpufreq_06.sh              |   46 +++---
 cpufreq/cpufreq_07.sh              |   47 +++----
 cpufreq/cpufreq_08.sh              |   26 ++--
 cpufreq/cpufreq_09.sh              |   28 ++--
 cpufreq/cpufreq_sanity.sh          |   10 +-
 cpuhotplug/1_sanity_check.sh       |   40 ------
 cpuhotplug/1_sanity_check.txt      |    1 -
 cpuhotplug/Android.mk              |    4 +-
 cpuhotplug/cpuhotplug_00.sh        |   40 ++++++
 cpuhotplug/cpuhotplug_00.txt       |    1 +
 cpuhotplug/cpuhotplug_01.sh        |    5 +-
 cpuhotplug/cpuhotplug_02.sh        |   23 ++-
 cpuhotplug/cpuhotplug_03.sh        |   18 ++-
 cpuhotplug/cpuhotplug_04.sh        |   17 +--
 cpuhotplug/cpuhotplug_05.sh        |   13 +-
 cpuhotplug/cpuhotplug_06.sh        |   15 +-
 cpuhotplug/cpuhotplug_07.sh        |   26 ++--
 cpuhotplug/cpuhotplug_08.sh        |   22 +--
 cpuhotplug/cpuhotplug_99.sh        |   40 ++++++
 cpuhotplug/cpuhotplug_99.txt       |    1 +
 cpuhotplug/cpuhotplug_sanity.sh    |    6 +-
 cpuhotplug/z_sanity_check.sh       |   40 ------
 cpuhotplug/z_sanity_check.txt      |    1 -
 cpuidle/cpuidle_01.sh              |   18 ++-
 cpuidle/cpuidle_02.sh              |    6 +-
 cpuidle/cpuidle_03.sh              |   16 +--
 cpuidle/cpuidle_sanity.sh          |    7 +-
 cputopology/Android.mk             |    2 +-
 cputopology/cputopology_01.sh      |    9 +-
 cputopology/cputopology_02.sh      |    4 +-
 cputopology/cputopology_sanity.sh  |   49 +++++++
 cputopology/cputopology_sanity.txt |    1 +
 include/functions.sh               |  274 +++++++++++++++++-------------------
 include/suspend_functions.sh       |   21 +--
 include/thermal_functions.sh       |  215 ++++++++++++++--------------
 powertop/powertop_01.sh            |   19 ++-
 powertop/powertop_sanity.sh        |    7 +-
 suspend/suspend_01.sh              |    6 +-
 suspend/suspend_02.sh              |    8 +-
 suspend/suspend_03.sh              |    6 +-
 suspend/suspend_04.sh              |    6 +-
 suspend/suspend_05.sh              |   14 +-
 suspend/suspend_sanity.sh          |    4 +-
 thermal/thermal_00.sh              |   22 +--
 thermal/thermal_01.sh              |   43 +++---
 thermal/thermal_02.sh              |   42 +++---
 thermal/thermal_03.sh              |   18 +--
 thermal/thermal_04.sh              |   59 ++++----
 thermal/thermal_05.sh              |   50 +++----
 thermal/thermal_06.sh              |   96 +++++++------
 thermal/thermal_sanity.sh          |    7 +-
 utils/utils_sanity.sh              |    4 +-
 59 files changed, 827 insertions(+), 828 deletions(-)
 delete mode 100755 cpuhotplug/1_sanity_check.sh
 delete mode 100644 cpuhotplug/1_sanity_check.txt
 create mode 100755 cpuhotplug/cpuhotplug_00.sh
 create mode 100644 cpuhotplug/cpuhotplug_00.txt
 create mode 100755 cpuhotplug/cpuhotplug_99.sh
 create mode 100644 cpuhotplug/cpuhotplug_99.txt
 delete mode 100755 cpuhotplug/z_sanity_check.sh
 delete mode 100644 cpuhotplug/z_sanity_check.txt
 create mode 100755 cputopology/cputopology_sanity.sh
 create mode 100644 cputopology/cputopology_sanity.txt

-- 
1.7.9.5


_______________________________________________
linaro-dev mailing list
linaro-dev@lists.linaro.org
http://lists.linaro.org/mailman/listinfo/linaro-dev

Reply via email to