On 19 January 2015 at 22:55, Amit Kucheria <amit.kuche...@linaro.org> wrote: > On Tue, Jan 20, 2015 at 6:06 AM, Lisa Nguyen <lisa.ngu...@linaro.org> wrote: >> [ It's been long overdue and PM-QA gets a makeover... ] > > Indeed. > >> This patchset primarily fixes Linaro Bug# 772 >> (https://bugs.linaro.org/show_bug.cgi?id=772) to remove >> bashisms in all PM-QA scripts. These scripts will run on >> Android, Openembedded, and Ubuntu. > > Sorry, but I don't like the way you've split up patches 1-9 by > directory. Can you merge them back and split them up by "change" > across directories. (Great use for git add -p) > e.g. All bash -> sh changes can be one patch, all replacing source > with . could be another and so on. This makes it easier to review > similar changes together. Use your judgement to merge several trivial > changes together in one patch. > > -#!/bin/bash > +#!/bin/sh > > -source ../include/functions.sh > +. ../include/functions.sh
Sure, not a problem. Will remerge and split into logical changes instead for v2. Thanks for the feedback. >> Cleanups have been done to remove redundant code, improve >> readability, and resolve syntax errors that were not >> detected before. >> >> Next steps: >> >> Once this patchset has been reviewed and acked, the following >> steps will be taken: >> >> 1. Submit a patch to update the release tag on the pwrmgmt >> test definitions to pm-qa-v0.5.0 >> >> 2. Submit a patch to update the pm-qa script >> (https://git.linaro.org/qa/test-definitions.git/blob/HEAD:/common/scripts/pm-qa.sh) >> used to run PM-QA on Android by removing unnecessary busybox sym >> links and replace suspend test module with thermal in >> directory list. >> >> 3. Investigate further on why pandaboards do not like the >> cpuidle_03 test case. >> >> Comments and/or questions are highly encouraged. >> >> Lisa Nguyen (18): >> functions: Remove bashisms in function scripts >> cpuidle: Remove bashisms in cpuidle test module >> cputopology: Remove bashisms in cputopology test module >> cpufreq: Remove bashisms in cpufreq test module >> thermal: Remove bashisms in thermal test module >> cpuhotplug: Remove bashisms in cpuhotplug scripts >> suspend: Remove bashisms in suspend test module >> utils: Remove bashisms in utils_sanity.sh >> powertop: Remove bashisms in powertop test module >> Test.mk: Add sort function >> Switches: Export hotplug_allow_cpu0 >> Add cputopology_sanity script >> cpuhotplug: Rename 1_sanity_check.sh to cpuhotplug_00.sh >> cpuhotplug: Rename z_sanity_check.sh to cpuhotplug_09.sh >> Add descriptions for cpuhotplug_00.sh and cpuhotplug_09.sh >> Switches: Remove thermal_try_max variable >> cpufreq: Rewrite logic to check for userspace and powersave governors >> Android.mk: Update test numbers and remove whitespace >> >> Switches.sh | 6 +- >> Test.mk | 4 +- >> cpufreq/Android.mk | 2 +- >> cpufreq/cpufreq_01.sh | 4 +- >> cpufreq/cpufreq_02.sh | 5 +- >> cpufreq/cpufreq_03.sh | 13 +- >> cpufreq/cpufreq_04.sh | 16 ++- >> cpufreq/cpufreq_05.sh | 24 ++-- >> cpufreq/cpufreq_06.sh | 59 ++++----- >> cpufreq/cpufreq_07.sh | 48 ++++--- >> cpufreq/cpufreq_08.sh | 31 ++--- >> cpufreq/cpufreq_09.sh | 27 ++-- >> cpufreq/cpufreq_sanity.sh | 9 +- >> cpuhotplug/1_sanity_check.sh | 40 ------ >> cpuhotplug/1_sanity_check.txt | 1 - >> cpuhotplug/Android.mk | 18 +-- >> cpuhotplug/cpuhotplug_00.sh | 39 ++++++ >> cpuhotplug/cpuhotplug_00.txt | 1 + >> cpuhotplug/cpuhotplug_01.sh | 5 +- >> cpuhotplug/cpuhotplug_02.sh | 21 ++-- >> cpuhotplug/cpuhotplug_03.sh | 15 ++- >> cpuhotplug/cpuhotplug_04.sh | 21 ++-- >> cpuhotplug/cpuhotplug_05.sh | 13 +- >> cpuhotplug/cpuhotplug_06.sh | 16 ++- >> cpuhotplug/cpuhotplug_07.sh | 17 ++- >> cpuhotplug/cpuhotplug_08.sh | 23 ++-- >> cpuhotplug/cpuhotplug_09.sh | 39 ++++++ >> cpuhotplug/cpuhotplug_09.txt | 1 + >> cpuhotplug/cpuhotplug_sanity.sh | 5 +- >> cpuhotplug/z_sanity_check.sh | 40 ------ >> cpuhotplug/z_sanity_check.txt | 1 - >> cpuidle/Android.mk | 4 +- >> cpuidle/cpuidle_01.sh | 21 ++-- >> cpuidle/cpuidle_02.sh | 7 +- >> cpuidle/cpuidle_03.sh | 17 ++- >> cpuidle/cpuidle_sanity.sh | 9 +- >> cputopology/Android.mk | 2 +- >> cputopology/cputopology_01.sh | 9 +- >> cputopology/cputopology_02.sh | 5 +- >> cputopology/cputopology_sanity.sh | 49 ++++++++ >> include/functions.sh | 248 >> +++++++++++++++++-------------------- >> include/suspend_functions.sh | 24 ++-- >> include/thermal_functions.sh | 219 ++++++++++++++++---------------- >> powertop/powertop_01.sh | 19 ++- >> powertop/powertop_sanity.sh | 8 +- >> suspend/suspend_01.sh | 9 +- >> suspend/suspend_02.sh | 9 +- >> suspend/suspend_03.sh | 9 +- >> suspend/suspend_04.sh | 11 +- >> suspend/suspend_05.sh | 11 +- >> suspend/suspend_sanity.sh | 4 +- >> thermal/thermal_00.sh | 22 ++-- >> thermal/thermal_01.sh | 39 +++--- >> thermal/thermal_02.sh | 36 +++--- >> thermal/thermal_03.sh | 18 +-- >> thermal/thermal_04.sh | 37 +++--- >> thermal/thermal_05.sh | 30 ++--- >> thermal/thermal_06.sh | 92 +++++++------- >> thermal/thermal_sanity.sh | 7 +- >> utils/utils_sanity.sh | 4 +- >> 60 files changed, 759 insertions(+), 784 deletions(-) >> delete mode 100755 cpuhotplug/1_sanity_check.sh >> delete mode 100644 cpuhotplug/1_sanity_check.txt >> create mode 100755 cpuhotplug/cpuhotplug_00.sh >> create mode 100644 cpuhotplug/cpuhotplug_00.txt >> create mode 100755 cpuhotplug/cpuhotplug_09.sh >> create mode 100644 cpuhotplug/cpuhotplug_09.txt >> delete mode 100755 cpuhotplug/z_sanity_check.sh >> delete mode 100644 cpuhotplug/z_sanity_check.txt >> create mode 100755 cputopology/cputopology_sanity.sh >> >> -- >> 1.7.9.5 >> -- Lisa Nguyen, PM-QA test suite co-maintainer Power Management Working Group Linaro.org │ Open source software for ARM SoCs | irc: lisatn | lisa.ngu...@linaro.org _______________________________________________ linaro-dev mailing list linaro-dev@lists.linaro.org http://lists.linaro.org/mailman/listinfo/linaro-dev