Hi Ian, Looks good mostly, though I haven't compiled anything yet. I just have a few comments for you.
Thanks, Patrick http://codereview.appspot.com/2204044/diff/7001/flower/include/guile-compatibility.hh File flower/include/guile-compatibility.hh (right): http://codereview.appspot.com/2204044/diff/7001/flower/include/guile-compatibility.hh#newcode29 flower/include/guile-compatibility.hh:29: #define scm_from_unsigned(x) scm_from_unsigned_integer (x) Why keep these if you don't want to use scm_{to,from}_unsigned() anywhere? Also, the scm_{to,from}_unsigned_integer() functions were introduced at the very beginning of the 1.7.* series, so I don't think we need any compatibility macros here. http://codereview.appspot.com/2204044/diff/7001/flower/include/guile-compatibility.hh#newcode30 flower/include/guile-compatibility.hh:30: #else // SCM_MINOR_VERSION > 6 && SCM_MINOR_VERSION < 9 For clarity, I would write #else // SCM_MINOR_VERSION >= 9 http://codereview.appspot.com/2204044/diff/7001/flower/include/guile-compatibility.hh#newcode35 flower/include/guile-compatibility.hh:35: #else // SCM_MAJOR_VERSION == 1 And here: #else // SCM_MAJOR_VERSION != 1 This helps me see that this is an else block http://codereview.appspot.com/2204044/diff/7001/lily/grob-array-scheme.cc File lily/grob-array-scheme.cc (right): http://codereview.appspot.com/2204044/diff/7001/lily/grob-array-scheme.cc#newcode45 lily/grob-array-scheme.cc:45: vsize i = scm_to_uint32 (index); Regarding my comments in the previous file, please change to vsize i = scm_to_unsigned_integer (index); instead. http://codereview.appspot.com/2204044/ _______________________________________________ lilypond-devel mailing list lilypond-devel@gnu.org http://lists.gnu.org/mailman/listinfo/lilypond-devel