Erik Sandberg escreveu:
hi,

In my quest for softcoding context-defs, I will need to revisit the \alias system. This is not on the top of my todo, but I'd like to hear any protests early.

I suggest that the \alias mechanism is scrapped altogether, and replaced with something else:
- junk Bottom alias, instead make is_bottom_context accessible from scheme.
- other aliases are replaced with appropriate boolean context properties, with more intuitive names (e.g. property 'isLyricMelody replaces current \alias Voice).

I think this will be an improvement, because we remove the concept of aliases, which confuses users (at least it confuses me a bit); in addition we don't need to do anything extra to softcode aliases.

I don't understand. How will this work in practice?  Ie. if I do

  \set Timing.measurePosition = #..

how will it be processed?

--

Han-Wen Nienhuys - [EMAIL PROTECTED] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
 -- Code for Music Notation
http://www.lilypond-design.com



_______________________________________________
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel

Reply via email to