> if (foo.equalsAsciiL(RTL_CONSTASCII_STRINGPARAM("XXXXX")))
> if (foo.equals(rtl::OUString(RTL_CONSTASCII_USTRINGPARAM("XXXXX"))))
>
> can be written as
>
> if( foo == "XXXXX" )

This has to be the biggest improvement in OOo/LO codebase readability
ever! Incredibly nice!

--tml
_______________________________________________
LibreOffice mailing list
LibreOffice@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/libreoffice

Reply via email to