Re-connection of my WiFi-STA to the AP can be slow, in case of previous 
disconnect.
According to the logs (see below), there is an increasing delay in scheduling 
retries from wpa_supplicant.
Is there an option to avoid this 'progressive' retry cycle, and have a fixed 
one instead ?

Another suspicion, I have for this effect: Is netifd triggering the retries to 
re-connect,
and somehow implements the progressive delay ?

If yes, how/where to modify ?


config interface 'wup'
        option proto 'dhcp'
        option ipv6 '0'
        option defaultroute '0'
        option peerdns '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path '101c0000.ehci/usb1/1-1/1-1.4/1-1.4:1.0'
        option htmode 'HT20'
        option log_level '3'

config wifi-iface
        option device 'radio1'
        option mode 'sta'
        option ssid 'xxxxxxxx'
        option encryption 'psk2'
        option key 'yyyyyyyy'
        option network 'wup'


wpa_cli:
> log_level DEBUG
OK
......
<3>CTRL-EVENT-SCAN-RESULTS
<3>SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='xxxxx' freq=2462 
MHz)
!!!!!!!!!!!!!!!!!!!!!!!
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="xxxxx" auth_failures=1 duration=10 
reason=CONN_FAILED
!!!!!!!!!!!!!!!!!!!!!!!!!
......
<3>SME: Trying to authenticate with xx:xx:xx:xx:xx:xx (SSID='xxxxx' freq=2462 
MHz)
!!!!!!!!!!!!!!!!!!!!!!!!!!
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="xxxxx" auth_failures=3 duration=30 
reason=CONN_FAILED
!!!!!!!!!!!!!!!!!!!!!!!


logread:
Mon Apr 10 04:31:20 2017 kern.info kernel: [69580.050000] wlan1: authentication 
with xx:xx:xx:xx:xx:xx timed out
Mon Apr 10 04:32:55 2017 kern.info kernel: [69674.650000] wlan1: authenticate 
with xx:xx:xx:xx:xx:xx            
Mon Apr 10 04:32:55 2017 kern.info kernel: [69674.740000] wlan1: send auth to 
xx:xx:xx:xx:xx:xx (try 1/3)
Mon Apr 10 04:32:55 2017 kern.info kernel: [69674.770000] wlan1: send auth to 
xx:xx:xx:xx:xx:xx (try 2/3)
Mon Apr 10 04:32:55 2017 kern.info kernel: [69674.800000] wlan1: send auth to 
xx:xx:xx:xx:xx:xx (try 3/3)
Mon Apr 10 04:32:55 2017 kern.info kernel: [69674.820000] wlan1: authentication 
with xx:xx:xx:xx:xx:xx timed out
Mon Apr 10 04:34:26 2017 kern.info kernel: [69765.900000] wlan1: authenticate 
with xx:xx:xx:xx:xx:xx            
Mon Apr 10 04:34:26 2017 kern.info kernel: [69765.990000] wlan1: send auth to 
xx:xx:xx:xx:xx:xx (try 1/3)



Regards,
--


Reiner Karlsberg


_______________________________________________
Lede-dev mailing list
Lede-dev@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/lede-dev

Reply via email to