I just flashed a brand new tl-wr940n and the network wasn't configured
correctly on the first boot.
I needed to start it in recovery mode, otherwise LAN was not reachable.

This is the generated invalid default config:
---
...
config interface 'lan'
        option type 'bridge'
        option ifname 'eth1 eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4t'

...
---

I changed it to this one an now LAN + WAN is working properly.
---
...
config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
...
---


Somebody here has the same router and can verify this ?

-- 
Regards

Daniel Danzberger
embeDD GmbH, Breitenweg 10, CH-6370 Stans

_______________________________________________
Lede-dev mailing list
Lede-dev@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/lede-dev

Reply via email to