Hi Jan-Tarek,
Am Fri, 30 Sep 2016 22:02:24 +0200 schrieb Jan-Tarek Butt <ta...@ring0.de>: > --- > scripts/getver.sh | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/scripts/getver.sh b/scripts/getver.sh > index f8b4ed3..27f246e 100755 > --- a/scripts/getver.sh > +++ b/scripts/getver.sh > @@ -25,8 +25,8 @@ try_git() { > ;; > *) > BRANCH="$(git rev-parse --abbrev-ref HEAD)" > - ORIGIN="$(git rev-parse --verify --symbolic-full-name > "${BRANCH}"@{u} 2>/dev/null)" > - [ -n "$ORIGIN" ] || ORIGIN="$(git rev-parse --verify > --symbolic-full-name master@{u} 2>/dev/null)" > + ORIGIN="$(git rev-parse --verify --symbolic-full-name > "${BRANCH}"@'{'u'}' 2>/dev/null)" > + [ -n "$ORIGIN" ] || ORIGIN="$(git rev-parse --verify > --symbolic-full-name master@'{'u'}' 2>/dev/null)" REV="$(git rev-list > ${REBOOT}.."$GET_REV" | wc -l | awk '{print $1}')" > if [ -n "$ORIGIN" ]; then out of curiosity: does this prevent a potential problem or is it just a clarification for better readability? Lars _______________________________________________ Lede-dev mailing list Lede-dev@lists.infradead.org http://lists.infradead.org/mailman/listinfo/lede-dev