On 22-1-2023 12:39, Martin Frb via lazarus wrote:
They should be called AnsiCodepoint UniCodeCodePoint
No, since in the case of a surrogate it is not a codepoint either. It is the unit of encoding granularity, nothing more.
But anyway, that ship sailed in (D)2009. It is probably the ever lasting tension between easier transition and long term best nomenclature.
So people will be reminded that they do not contain characters (they may by coincidence, but software should not be build on coincidence)
I have some doubts about such simple nomenclature really explaining something as complex as unicode. It will never be intuitive and always need study.
-- _______________________________________________ lazarus mailing list lazarus@lists.lazarus-ide.org https://lists.lazarus-ide.org/listinfo/lazarus