On 4 September 2015 at 08:43, Jon Neal <[email protected]> wrote: > I'm a stickler for code that uses the same conventions when possible. > m_drawatzero should be camelCase instead of all lowercase. :)
I'll change that, no worries. > + switch( m_style & 0xFF ) > I'm curious as to what that is doing. m_style is of type MARKER_STYLE > which is an enum with 7 items in it. Sorry, as mentioned that's an old artefact from when I had used CIRCLE as a flag as to whether or not to draw the circle of the marker. That looked horrid though, so I removed it (or at least I thought I'd removed all of it!) > In enum MARKER_STYLE it may be nice to spell out more explicitly CIRCLE_DOT, > CIRCLE_CROSS, CIRCLE_X (I'm assuming the C means circle) to make the code a > bit more readable. Yeah, may be better - it's how it started, but then I shortened it. Best Regards, Brian. _______________________________________________ Mailing list: https://launchpad.net/~kicad-developers Post to : [email protected] Unsubscribe : https://launchpad.net/~kicad-developers More help : https://help.launchpad.net/ListHelp

