Hi X86 maintainers, Andrew, On 02/07/25 at 04:08pm, Coiby Xu wrote: ......snip... > This patch set only supports x86. There will be patches to support other > architectures once this patch set gets merged.
who can help pick this patchset? It has been under many rounds of reviewing, now it's ready for merging from kdump reviewers' side. Or any comments or concern for further work? Thanks Baoquan > > v8 > - improve documentation [Randy] > - rebase onto 6.14.0-rc1 > > v7 > - Baoquan > - differentiate between failing to get dm crypt keys and no dm crypt keys > - add code comments, change function name and etc. to improve code > readability > - add documentation for configfs API [Dave] > - fix building error found by kernel test robot > > v6 > - Baoquan > - support AMD SEV > - drop uncessary keys_header_size > - improve commit message of [PATCH 4/7] > > - Greg > - switch to configfs > - move ifdef from .c to .h files and rework kexec_random_start > - use tab instead of space for appended code comment > > - Process key description in a more flexible way to address problems > found by Ondrej > - improve cover letter > - fix an compilation error as found by kernel test robot > > v5 > - Baoquan > - limit the feature of placing kexec_buf randomly to kdump > (CONFIG_CRASH_DUMP) > - add documentation for added sysfs API > - allow to re-send init command to support the case of user switching to > a different LUKS-encrypted target > - make CONFIG_CRASH_DM_CRYPT depends on CONFIG_DM_CRYPT > - check if the number of keys exceed KEY_NUM_MAX > - rename (struct keys_header).key_count as (struct keys_header).total_keys > to improve code readability > - improve commit message > - fix the failure of calling crash_exclude_mem_range (there is a split > of mem_range) > - use ret instead of r as return code > > - Greg > - add documentation for added sysfs API > - avoid spamming kernel logs > - fix a buffer overflow issue > - keep the state enums synced up with the string values > - use sysfs_emit other than sprintf > - explain KEY_NUM_MAX and KEY_SIZE_MAX > - s/EXPORT_SYMBOL_GPL/EXPORT_SYMBOL/g > - improve code readability > > - Rebase onto latest Linus tree > > > v4 > - rebase onto latest Linus tree so Baoquan can apply the patches for > code review > - fix kernel test robot warnings > > v3 > - Support CPU/memory hot-plugging [Baoquan] > - Don't save the keys temporarily to simplify the implementation [Baoquan] > - Support multiple LUKS encrypted volumes > - Read logon key instead of user key to improve security [Ondrej] > - A kernel config option CRASH_DM_CRYPT for this feature (disabled by > default) > - Fix warnings found by kernel test robot > - Rebase the code onto 6.9.0-rc5+ > > v2 > - work together with libscryptsetup's > --link-vk-to-keyring/--volume-key-keyring APIs [Milan and Ondrej] > - add the case where console virtual keyboard is untrusted for confidential > VM > - use dm_crypt_key instead of LUKS volume key [Milan and Eric] > - fix some code format issues > - don't move "struct kexec_segment" declaration > - Rebase the code onto latest Linus tree (6.7.0) > > v1 > - "Put the luks key handling related to crash_dump out into a separate > file kernel/crash_dump_luks.c" [Baoquan] > - Put the generic luks handling code before the x86 specific code to > make it easier for other arches to follow suit [Baoquan] > - Use phys_to_virt instead of "pfn -> page -> vaddr" [Dave Hansen] > - Drop the RFC prefix [Dave Young] > - Rebase the code onto latest Linus tree (6.4.0-rc4) > > RFC v2 > - libcryptsetup interacts with the kernel via sysfs instead of "hacking" > dm-crypt > - to save a kdump copy of the LUKS volume key in 1st kernel > - to add a logon key using the copy for libcryptsetup in kdump kernel > [Milan] > - to avoid the incorrect usage of LUKS master key in dm-crypt [Milan] > - save the kdump copy of LUKS volume key randomly [Jan] > - mark the kdump copy inaccessible [Pingfan] > - Miscellaneous > - explain when operations related to the LUKS volume key happen [Jan] > - s/master key/volume key/g > - use crash_ instead of kexec_ as function prefix > - fix commit subject prefixes e.g. "x86, kdump" to x86/crash > > > Coiby Xu (7): > kexec_file: allow to place kexec_buf randomly > crash_dump: make dm crypt keys persist for the kdump kernel > crash_dump: store dm crypt keys in kdump reserved memory > crash_dump: reuse saved dm crypt keys for CPU/memory hot-plugging > crash_dump: retrieve dm crypt keys in kdump kernel > x86/crash: pass dm crypt keys to kdump kernel > x86/crash: make the page that stores the dm crypt keys inaccessible > > Documentation/admin-guide/kdump/kdump.rst | 32 ++ > arch/x86/kernel/crash.c | 26 +- > arch/x86/kernel/kexec-bzimage64.c | 11 + > arch/x86/kernel/machine_kexec_64.c | 22 ++ > include/linux/crash_core.h | 7 +- > include/linux/crash_dump.h | 2 + > include/linux/kexec.h | 34 ++ > kernel/Kconfig.kexec | 10 + > kernel/Makefile | 1 + > kernel/crash_dump_dm_crypt.c | 459 ++++++++++++++++++++++ > kernel/kexec_file.c | 3 + > 11 files changed, 604 insertions(+), 3 deletions(-) > create mode 100644 kernel/crash_dump_dm_crypt.c > > > base-commit: bb066fe812d6fb3a9d01c073d9f1e2fd5a63403b > -- > 2.48.1 >