bruns marked 2 inline comments as done.
bruns added inline comments.

INLINE COMMENTS

> hallas wrote in fstabdevice.cpp:62
> Would it make sense to wrap this in a function with a more expressive name 
> like: isEncryptedFilesystem or isValutFilesystem? Then we could use the same 
> function in fstabhandling.cpp:126

I don't think there is much to gain here - as the function is trivial, we 
should inline it. To keep the code easy to understand, the function name has to 
be really expressive. On the next fuse filesystem added, it may become quite 
different.

> hallas wrote in fstabdevice.cpp:172
> Why do we create a new FstabNetworkShare everytime this function is called 
> with NetworkShare but we return the same object instance when it is a 
> StorageAccess?

The storageAccess is also used internally, for the `emblems()` method. Creating 
it on each call would be to expensive, especially as it has quite some signals 
connected, also DBus signals.
NetworkShare is quite lightweight. There is no reason it couldn't be cached, 
but hardly any benefit.

REPOSITORY
  R245 Solid

BRANCH
  fstab_generic

REVISION DETAIL
  https://phabricator.kde.org/D21041

To: bruns, #frameworks, ngraham, hallas
Cc: broulik, kde-frameworks-devel, michaelh, ngraham, bruns

Reply via email to