dfaure accepted this revision. dfaure added inline comments. INLINE COMMENTS
> file.cpp:304 > + bool dirCreated; > + if (!(dirCreated = QDir().mkdir(path))) { > + if (auto err = execWithElevatedPrivilege(MKDIR, path)) { moving this to the line above would be simpler / more readable: bool dirCreated = QDir().mkdir(path); if (!dirCreated) { REPOSITORY R241 KIO BRANCH master REVISION DETAIL https://phabricator.kde.org/D6831 To: chinmoyr, dfaure, #frameworks Cc: dhaumann, #frameworks