ahmadsamir added a comment.
There are only two places in KDE code where readEntryList() is used, falkon and kwalletmanager; in both cases readEntryList() was used with "*" which means "read all entries", which is logical since in both cases the list is used to fill a "password manager" of some kind. I am thinking of having 3 new methods (right now there is read{Entry, Map, Password}List, very intuitively replace "read" with "get") that take a third parameter: enum KWallet::MatchType {KWallet::PlainText, KWallet::Regex} this way in regex mode, the QString &key parameter is used to construct a QRegularExpression, abstracting the type of the regex class (nitpicking really, since given QRegExp has been around for what 10/15 years? QRegularExpression may live even longer with sturdy PCRE support o/...). New method names solve some hurdles (e.g. overloading a function that takes only one QString param, and it actually invoked by a dbus call). In the meantime: https://marc.info/?t=146788789300003&r=1&w=2 , can't say I understood all the issues there but it's definitely a grim read :) REPOSITORY R311 KWallet REVISION DETAIL https://phabricator.kde.org/D28880 To: ahmadsamir, #frameworks, dfaure, blaze Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns