----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://git.reviewboard.kde.org/r/112679/#review39864 -----------------------------------------------------------
staging/kservice/src/services/ktraderparsetree.cpp <http://git.reviewboard.kde.org/r/112679/#comment29393> This 5 line block is duplicated in a number of methods. Instead, add a _context->property(...) which encapsulates the dispatch into service or info. staging/kservice/src/services/ktraderparsetree.cpp <http://git.reviewboard.kde.org/r/112679/#comment29394> kdelibs coding style -> if (service) { staging/kservice/src/services/ktraderparsetree.cpp <http://git.reviewboard.kde.org/r/112679/#comment29395> kdelibs coding style -> no space inside (), '{' on the same line. foreach() would be more readable, too. staging/kservice/src/services/ktraderparsetree_p.h <http://git.reviewboard.kde.org/r/112679/#comment29392> Remove the const and & from here -> problem solved. (same on the line above) - David Faure On Sept. 12, 2013, 1:33 a.m., Sebastian Kügler wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > http://git.reviewboard.kde.org/r/112679/ > ----------------------------------------------------------- > > (Updated Sept. 12, 2013, 1:33 a.m.) > > > Review request for KDE Frameworks and David Faure. > > > Description > ------- > > This patch allows search through KPluginInfo::List, additionally to > KService::List. Together with the other patches from my set It makes it > possible to search through the plugin's (JSON-based) metadata, using our > constraint syntax. > > It adds a ctor that takes a KPluginInfo::List& and adds the necessary > branches to look within either the KService::List or the KPluginInfo::List. > > There's one problem I don't know an elegant solution to, will point that out > in the diff. > > > This, and the other patches from this set are also in > kdelibs[sebas/pluginlocator] > > > Diffs > ----- > > staging/kservice/src/services/ktraderparsetree.cpp 4257e43 > staging/kservice/src/services/ktraderparsetree_p.h 7664943 > > Diff: http://git.reviewboard.kde.org/r/112679/diff/ > > > Testing > ------- > > - Added tests (separate review), all pass > - Ported Plasma::PluginLoader from KServiceTypeTrader to KPluginTrader and > tested the querying in a real-world scenario, no regressions spotted > - No regressions in existing tests > > > Thanks, > > Sebastian Kügler > >
_______________________________________________ Kde-frameworks-devel mailing list Kde-frameworks-devel@kde.org https://mail.kde.org/mailman/listinfo/kde-frameworks-devel