On Dienstag, 29. Oktober 2024 09:43:06 Mitteleuropäische Normalzeit Sune Vuorela wrote: > On 2024-10-28, Albert Astals Cid <aa...@kde.org> wrote: > > My vote goes for rename the variable, there's 2 reasons i can think why > > you do
I second this. I dislike symbol shadowing more than I dislike having to find a name that doesn't shadow some symbol. Just the other day I was confused why I couldn't call the error() function defined in the base class in a derived class. It turned out that someone thought it'd be a good idea to call a member variable "error". I renamed this member variable. Regards, Ingo
signature.asc
Description: This is a digitally signed message part.