https://bugs.kde.org/show_bug.cgi?id=405746

            Bug ID: 405746
           Summary: Rename and reorganize some Create New Document's
                    Custom Document names and options
           Product: krita
           Version: unspecified
          Platform: Other
                OS: Linux
            Status: REPORTED
          Severity: normal
          Priority: NOR
         Component: General
          Assignee: krita-bugs-n...@kde.org
          Reporter: tysont...@gmail.com
  Target Milestone: ---

Right now Custom Document in Create New Document dialogue has quite a few
confusing item arrangements.

1) Color space related stuff is under the Dimension tab.
Suggestion: Make a new Color Space tab and put color space stuff there.


2) The "Color" string should be renamed to "Color Management" or "Color Space".


3) This "Color" string is being used in way too many different context:

#. i18n: ectx: property (title), widget (QGroupBox, grpMode)
#. i18n: ectx: property (text), widget (KColorButton, colorSelector)
#. i18n: ectx: property (text), widget (KColorButton, colorFillSelector)
#. i18n: ectx: property (text), item, widget (QComboBox, cmbFillType)
#. i18n: ectx: property (title), widget (QGroupBox, groupBox_2)
#: libs/pigment/compositeops/KoCompositeOps.h:190
#: libs/pigment/KoCompositeOp.cpp:31 libs/pigment/KoCompositeOpRegistry.cpp:105
#: libs/ui/dialogs/kis_dlg_preferences.cc:1177
#: libs/ui/forms/wdgnewimage.ui:66
libs/ui/forms/wdgstrokeselectionproperties.ui:150
#: libs/ui/forms/wdgstrokeselectionproperties.ui:188
#: libs/ui/kis_palette_view.cpp:102 libs/ui/kis_palette_view.cpp:328
#: libs/ui/layerstyles/WdgColorOverlay.ui:23
#: libs/ui/layerstyles/WdgStroke.ui:134
plugins/color/lcms2engine/compositeops/RgbCompositeOpColor.h:38
#: plugins/extensions/layersplit/layersplit.cpp:202
#: plugins/generators/solid/colorgenerator.h:53
#, kde-format

But Color (pigments) is not really the same as Color (color management
context). In Chinese we have two different words for each: 颜色/色彩. But now we
are forced to use Color (pigment) in contexts of Color (Color management),
which is not completely wrong but irritating for a translator to do nothing but
allow a mistake. I suggest we make every Color string unique and do not reuse
them in any another context, this will greatly increase the accuracy of
translation.


3) Image Background Color and Opacity is for some reason defined in "Content"
tab.

Now these are the two options that SHOULD go under the name of "Color"...but
under the current arrangement it really has no place to go. I suggest we:

  1. Rename "Dimensions" tab to "Content"
  2. Move all Layer count and Image Background settings under the current
"Color" section
  3. Move all color space related stuff to a new "Color Space" tab
  4. Rename the current "Content" tab to "Metadata", it has only Name and
Description now.
  5. Same goes for Create from Clipboard.

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to