There are two (2) methods in the org.openjump.core.apitools that I think we should move to the com.vividsolutions.jump.util.CollectionUtil class. The first method is the org.openjump.core.apitools.CollectionTools.addArrayToList method. The second is the org.openjump.core.apitools.FeatureCollectionTools.resizeArray method.
I'm willing to make this move in OpenJUMP and ensure it doesn't break anything in the core. It will be a little more difficult to ensure things don't break in the PIROL plug-ins. We can certainly leave things the way they are, but I'd really like to consolidate some of the utility methods we've got laying all around the core. I think this type of maintenance needs to be done at some point, or the stink in our code base will only get worse with time. If someone is willing to help me track down the source code for the PIROL plug-ins, I would be willing to refactor them with the change as well. Let me know what you guys think. SS ------------------------------------------------------------------------------ _______________________________________________ Jump-pilot-devel mailing list Jump-pilot-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/jump-pilot-devel