A Array{Float64} isn't a subclass of Array{FloatingPoint} because you can't 
write any FloatingPoint value into an Array{Float64} without conversion. A 
function will sometimes need to modify the array, and then you might need both 
methods. 

We can definitely see the point about the current syntax for the most common 
need in a function signature is inconvenient. There are good (but really hard 
to understand) reasons for the current situation. I spent a long time before I 
got it. 

Reply via email to