Can't really see much wrong with the code, but it may be easier to
write your hide function like

J(parentDivIdHere).children().hide(10000);

Where the parent div is the the div containing #1201410000 ... etc.
But that depends on what you are trying to acheive.

You could also write it like

J(' "#1201410000", "#1201496400", "#1201582800"....').hide(10000);

Not sure if that helps readability or not.. :)

Maybe post a link to a demo of the problem.

Matt

On Feb 17, 2:19 am, "Michael Ray" <[EMAIL PROTECTED]> wrote:
> I am trying to define three functions within the $(document).ready()
> function. However, each of these functions only work if the other two are
> not there. I have to use noConflict mode because I am also using Protype as
> well. What is the proper syntax to define more than one function? Here's
> what I have right now:
>
> <script type="text/javascript">
>     var J = jQuery.noConflict();
>
>     J(document).ready(function(){
>         J('#slickbox').hide('slow');
>
>         J("#next").click(function(){
>             J("#1201410000").hide(10000)
>             J("#1201496400").hide(10000)
>             J("#1201582800").hide(10000)
>             J("#1201669200").hide(10000)
>             J("#1201755600").hide(10000)
>             J("#1201842000").hide(10000)
>             J("#1201928400").hide(10000)
>             return false;
>         });
>
>         J("#previous").click(function(){
>             J("#calendar").append('<h1>this is a test</h1>');
>             return false;
>         });
>     });
> </script>

Reply via email to