[
https://issues.apache.org/jira/browse/TS-4631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15360220#comment-15360220
]
Leif Hedstrom commented on TS-4631:
-----------------------------------
Are you sure? The code doesn't look identical, but maybe the semantics are? But
if they are identical, then the underlying structures in HttpSM should maybe be
cleaned up, since we have
{code}
t_state.server_info.dst_addr.sa;
{code}
vs
{code}
t_state.current.server->dst_addr.sa;
{code}
> remove TSHttpTxnNextHopAddrGet
> ------------------------------
>
> Key: TS-4631
> URL: https://issues.apache.org/jira/browse/TS-4631
> Project: Traffic Server
> Issue Type: Improvement
> Components: TS API
> Reporter: James Peach
> Fix For: sometime
>
>
> {{TSHttpTxnNextHopAddrGet}} is identical to {{TSHttpTxnServerAddrGet}}.
> Remove it since we don't need both.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)