[
https://issues.apache.org/jira/browse/TS-2823?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14004028#comment-14004028
]
ASF subversion and git services commented on TS-2823:
-----------------------------------------------------
Commit cb6e6f6a893cd06c62a92bc1bb41e6526dac207d in trafficserver's branch
refs/heads/master from [~amc]
[ https://git-wip-us.apache.org/repos/asf?p=trafficserver.git;h=cb6e6f6 ]
TS-2823: Change names of TSEvent and TSError in mgmt API
> Change names of Mgmt API types TSEvent and TSError
> --------------------------------------------------
>
> Key: TS-2823
> URL: https://issues.apache.org/jira/browse/TS-2823
> Project: Traffic Server
> Issue Type: Improvement
> Components: Console
> Reporter: Alan M. Carroll
> Assignee: Alan M. Carroll
>
> Now that we are using lib/ts/apidefs.h in the core, there is a collision
> between TSEvent and potentially TSError between definitions in apidefs.h and
> mgmtapi.h. The definitions are completely different and it seems wrong (and
> now a real problem) to have that name collision.
> The Mgmt API types will now be "TSMgmtEvent" and "TSMgmtError"
--
This message was sent by Atlassian JIRA
(v6.2#6252)