[
https://issues.apache.org/jira/browse/TS-1851?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13641167#comment-13641167
]
ASF subversion and git services commented on TS-1851:
-----------------------------------------------------
Commit 2915206c73f08dcb9d262dfa0f19967f20eaabdf in branch refs/heads/master
from [[email protected]]
[ https://git-wip-us.apache.org/repos/asf?p=trafficserver.git;h=2915206 ]
TS-1851: Remove HostDBInfo constructor so it becomes a POD
Somewhere down the line HostDBInfo grew enough constructor complexity
that it became a non-POD type. The allocation treats it like a POD
type, so we should make sure that the compiler agrees.
Rename HostDBRoundRobin::n to HostDBRoundRobin::rrcount. Remove
unused HostDBInfo::set_from
> turn HostDBInfo back into a POD type
> ------------------------------------
>
> Key: TS-1851
> URL: https://issues.apache.org/jira/browse/TS-1851
> Project: Traffic Server
> Issue Type: Bug
> Components: DNS
> Reporter: James Peach
> Assignee: James Peach
> Fix For: 3.3.3
>
>
> Somewhere down the line HostDBInfo grew enough constructor complexity that it
> became a non-POD type. The allocation treats it like a POD type, so we should
> make sure that the compiler treats is the same way.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira