[
https://issues.apache.org/jira/browse/SPARK-22426?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16236939#comment-16236939
]
Saisai Shao commented on SPARK-22426:
-------------------------------------
This kind of scenario was handled in SPARK-13669 regarding to blacklist
mechanism.
> Spark AM launching containers on node where External spark shuffle service
> failed to initialize
> -----------------------------------------------------------------------------------------------
>
> Key: SPARK-22426
> URL: https://issues.apache.org/jira/browse/SPARK-22426
> Project: Spark
> Issue Type: Bug
> Components: Shuffle, YARN
> Affects Versions: 1.6.3
> Reporter: Prabhu Joseph
> Priority: Major
>
> When Spark External Shuffle Service on a NodeManager fails, the remote
> executors will fail while fetching the data from the executors launched on
> this Node. Spark ApplicationMaster should not launch containers on this Node
> or not use external shuffle service.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]