[
https://issues.apache.org/jira/browse/SPARK-19260?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Sean Owen resolved SPARK-19260.
-------------------------------
Resolution: Fixed
Fix Version/s: 2.2.0
Issue resolved by pull request 16614
[https://github.com/apache/spark/pull/16614]
> Spaces or "%20" in path parameter are not correctly handled with
> HistoryServer
> -------------------------------------------------------------------------------
>
> Key: SPARK-19260
> URL: https://issues.apache.org/jira/browse/SPARK-19260
> Project: Spark
> Issue Type: Bug
> Components: Spark Core
> Affects Versions: 2.1.0
> Environment: linux
> Reporter: zuotingbing
> Priority: Minor
> Fix For: 2.2.0
>
>
> case1: .sbin/start-history-server.sh "file:/a b"
> And you get the error ===>
> Caused by: java.lang.IllegalArgumentException: Log directory specified does
> not exist: file:/root/file:/a%20b.
> at
> org.apache.spark.deploy.history.FsHistoryProvider.org$apache$spark$deploy$history$FsHistoryProvider$$startPolling(FsHistoryProvider.scala:201)
> case2: ./start-history-server.sh "/a%20c"
> And you get the error ===>
> Caused by: java.lang.IllegalArgumentException: Log directory specified does
> not exist: file:/a%2520c/.
> at
> org.apache.spark.deploy.history.FsHistoryProvider.org$apache$spark$deploy$history$FsHistoryProvider$$startPolling(FsHistoryProvider.scala:201)
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]