[
https://issues.apache.org/jira/browse/SPARK-19322?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Wei Liu updated SPARK-19322:
----------------------------
Description:
When creating StructType using ScalaRelfection.schemaFor, the column names are
defined by scala case class parameter names. This causes minor inconvenience
when reading/writing data between Python and Scala which follow different
naming conventions. Ideally, we should allow customize column names using Scala
annotations in a similar fashion to Jackson serialization libraries.
For example, we could define schema as :
case class MySchema(@fieldName("long_field") longField: Long,
@fieldName("int_field") intField: Int)
The field/column names can now be customized.
was:When creating StructType using Scalarelfection.schemaFor, the column
names are defined by scala case class parameter names. This causes minor
inconvenience when reading/writing data between Python and Scala. Ideally, we
should allow customize column names using Scala annotations in a similar
fashion to Jackson serialization libraries.
> Allow customizable column name in ScalaReflection.schemaFor
> -----------------------------------------------------------
>
> Key: SPARK-19322
> URL: https://issues.apache.org/jira/browse/SPARK-19322
> Project: Spark
> Issue Type: Improvement
> Components: Spark Core
> Affects Versions: 2.1.0
> Reporter: Wei Liu
> Priority: Minor
>
> When creating StructType using ScalaRelfection.schemaFor, the column names
> are defined by scala case class parameter names. This causes minor
> inconvenience when reading/writing data between Python and Scala which follow
> different naming conventions. Ideally, we should allow customize column names
> using Scala annotations in a similar fashion to Jackson serialization
> libraries.
> For example, we could define schema as :
> case class MySchema(@fieldName("long_field") longField: Long,
> @fieldName("int_field") intField: Int)
> The field/column names can now be customized.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]