[
https://issues.apache.org/jira/browse/SOLR-13136?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
ASF GitHub Bot updated SOLR-13136:
----------------------------------
Labels: pull-request-available (was: )
> Queries fail during shard creation [testcase included]
> ------------------------------------------------------
>
> Key: SOLR-13136
> URL: https://issues.apache.org/jira/browse/SOLR-13136
> Project: Solr
> Issue Type: Bug
> Components: SolrCloud
> Affects Versions: 7.6
> Reporter: Bram VD
> Priority: Major
> Labels: pull-request-available
> Attachments: TestSearchDuringShardCreation.java
>
> Time Spent: 10m
> Remaining Estimate: 0h
>
> Shard creation takes a certain amount of time. Queries launched between the
> start of shard creation and the full "upness" of the shard will fail: "Error
> from server at foo: no servers hosting shard: bar".
> Ideally, shards should not be used in queries before their creation is fully
> completed. A new shard is empty anyway, so its upness couldn't even influence
> the query results in any way.
> I'm attaching a testcase which reproduces the problem. Tested on two
> machines, but your mileage may vary assuming this is a concurrency issue.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]