[ https://issues.apache.org/jira/browse/SOLR-15258?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17300638#comment-17300638 ]
David Smiley commented on SOLR-15258: ------------------------------------- Perhaps as a part of this, rename Standalone to FileSystemConfigSetService (and move to top level), and maybe rename CloudConfigSetService to ZkConfigSetService? And have both with constructors that allow plugging in this explicitly via solr.xml if desired > ConfigSetService: add CRUD operations, subsume ZkConfigManager > --------------------------------------------------------------- > > Key: SOLR-15258 > URL: https://issues.apache.org/jira/browse/SOLR-15258 > Project: Solr > Issue Type: Improvement > Security Level: Public(Default Security Level. Issues are Public) > Reporter: David Smiley > Priority: Minor > > Increase the scope of ConfigSetService with CRUD operations and anything else > so that it can be the one place to go for anything ConfigSet related. This > should be easier to understand/maintain, and also improve the efficacy of the > plug-ability of ConfigSetService. > It's likely ZkConfigManager will disappear, with most of its functionality > moving into CloudConfigSetService (ZK). A number of places in SolrCloud use > ZkConfigManager that will change to use the ConfigSetService instead. -- This message was sent by Atlassian Jira (v8.3.4#803005)