[ 
https://issues.apache.org/jira/browse/IGNITE-24924?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Konstantin Orlov updated IGNITE-24924:
--------------------------------------
    Description: 
{{TransactionTracker}} is tracking operation within a particular transaction 
rather than transaction itself. Therefore it suggested to change the interface 
in the following way:
{code}
public interface TransactionalOperationTracker {
    boolean registerOperationStart(InternalTransaction tx);
    void registerOperationFinish(UUID txId);
}
{code}

Also it would be nice to improve {{QueryTransactionWrapper#commitImplicit}} as 
well, because it does not only commit implicit transaction, but also does 
finalization step for all type of transactions (for instance, it marks the end 
of operation, therefore this method must be invoked every time at the end of 
operation even when it's known that transaction is explicit).

  was:
{{TransactionTracker}} is tracking operation within a particular transaction 
rather than transaction itself. Therefore it suggested to change the interface 
in the following way:
{code}
public interface TransactionalOperationTracker {
    boolean registerOperationStart(InternalTransaction tx);
    void registerOperationFinish(UUID txId);
}
{code}


> Sql. Rename TransactionTracker to better reflect semantic
> ---------------------------------------------------------
>
>                 Key: IGNITE-24924
>                 URL: https://issues.apache.org/jira/browse/IGNITE-24924
>             Project: Ignite
>          Issue Type: Improvement
>          Components: sql
>            Reporter: Konstantin Orlov
>            Priority: Major
>              Labels: ignite-3
>
> {{TransactionTracker}} is tracking operation within a particular transaction 
> rather than transaction itself. Therefore it suggested to change the 
> interface in the following way:
> {code}
> public interface TransactionalOperationTracker {
>     boolean registerOperationStart(InternalTransaction tx);
>     void registerOperationFinish(UUID txId);
> }
> {code}
> Also it would be nice to improve {{QueryTransactionWrapper#commitImplicit}} 
> as well, because it does not only commit implicit transaction, but also does 
> finalization step for all type of transactions (for instance, it marks the 
> end of operation, therefore this method must be invoked every time at the end 
> of operation even when it's known that transaction is explicit).



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to