[ 
https://issues.apache.org/jira/browse/HIVE-20542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16624587#comment-16624587
 ] 

Sankar Hariappan edited comment on HIVE-20542 at 9/25/18 5:00 AM:
------------------------------------------------------------------

[~ashutosh.bapat], I've few comments
 # Need to use Java naming conventions for variables. Eg, dbname_val should be 
dbNameVal etc.
 # In addNotificationLoag method, seen similar issue where table name is set to 
" " (with single space) if it is not an input. Can we make it null if not 
available.
 # addNotificationLog can use event.getCatName()  to set catalogue name instead 
of always setting it to NULL.
 # getNotificationEventsCount can take an optional toEventId as it is allowed 
for incremental replication. Also, check if we can include LIMIT as well.
 # In  getNotificationEventsCount, can we use (dbName IS NULL) instead of 
(dbName == null)? Same with catalogName too.
 # Can add a unit test to verify if getNotificationEventsCount return proper 
count for events with db name and not.


was (Author: sankarh):
[~ashutosh.bapat], I've few comments
 # Need to use Java naming conventions for variables. Eg, dbname_val should be 
dbNameVal etc.
 # In addNotificationLoag method, seen similar issue where table name is set to 
" " (with single space) if it is not an input. Can we make it null if not 
available.
 # addNotificationLog can use event.getCatName()  to set catalogue name instead 
of always setting it to NULL.
 # getNotificationEventsCount can take an optional toEventId as it is allowed 
for incremental replication.
 # In  getNotificationEventsCount, can we use (dbName IS NULL) instead of 
(dbName == null)? Same with catalogName too.
 # Can add a unit test to verify if getNotificationEventsCount return proper 
count for events with db name and not.

> Incremental REPL DUMP progress information log message is incorrect.
> --------------------------------------------------------------------
>
>                 Key: HIVE-20542
>                 URL: https://issues.apache.org/jira/browse/HIVE-20542
>             Project: Hive
>          Issue Type: Bug
>          Components: repl
>    Affects Versions: 4.0.0, 3.2.0
>            Reporter: Sankar Hariappan
>            Assignee: Ashutosh Bapat
>            Priority: Minor
>              Labels: DR, Replication
>         Attachments: HIVE-20542.01.patch
>
>
> Incremental REPL DUMP have the progress information logged as 
> "eventsDumpProgress":"49/0".
> It should actually log the estimated number of events are denominator but it 
> is coming as 0 always.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to