[ https://issues.apache.org/jira/browse/HIVE-9971?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14362770#comment-14362770 ]
Gunther Hagleitner commented on HIVE-9971: ------------------------------------------ Oh there's also two minor nuisances: - processOp doesn't exist anymore. The contract in Operator is that xxx methods are template methods and xxxOp are the methods that the framework calls. With process that didn't work because it's the inner loop. So we nuked process and called processOp directly. Code would look much better though if we had nuked processOp and called everything process. - OpTraits should be called Traits. Like Statistics aren't called OpStatistics. Or children aren't called OpKids. > Clean up operator class > ----------------------- > > Key: HIVE-9971 > URL: https://issues.apache.org/jira/browse/HIVE-9971 > Project: Hive > Issue Type: Bug > Reporter: Gunther Hagleitner > Assignee: Gunther Hagleitner > Attachments: HIVE-9971.1.patch > > > This is mostly cleanup although it does enhance the pipeline in one respect. > It introduces asyn init for operators and uses it for hash table loading > where desired. > There's a bunch of weird code associated with the operator class: > - initialize isn't recursive, rather initializeOp is supposed to call > initializeChildren. That has led to bugs in the past. > - setExecContext and passExecContext. Both are recursive, but passExecContext > calls setExecContext and then recurses again. Boo. > - lots of (getChildren() != null) although that can't happen anymore > - TezCacheAccess is a hack. We should just leave init of inputs up to the > operator that needs it. > - Need some sanity checks that make sure that operators were all initialized. -- This message was sent by Atlassian JIRA (v6.3.4#6332)