[ 
https://issues.apache.org/jira/browse/FLINK-6257?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fabian Hueske updated FLINK-6257:
---------------------------------
    Description: 
The OVER windows have been implemented by several contributors.
We should do a post pass over the contributed code and improve a few things.

* Functionality
** Currently every time attribute is allowed as ORDER BY attribute. We must 
check that this is actually a time indicator ({{procTime()}}, {{rowTime()}}) 
and that the order is ASCENDING.
* Documentation
** Add documentation for OVER windows
* Code style
** Consistent naming of {{ProcessFunctions}} and methods
* Tests
** Move the OVER window tests out of SqlITCase into a dedicated class
** Move the OVER window tests out of WindowAggregateTest into a dedicated class
** Add tests based on the test harness for all {{ProcessFunctions}} similar to 
{{BoundedProcessingOverRangeProcessFunction}}. The tests should include exact 
boundary checks for range windows and check for proper parallelization with 
multiple keys.


  was:
The OVER windows have been implemented by several contributors.
We should do a post pass over the contributed code and:

* Functionality
** currently every time attributes is allows as ORDER BY attribute. We must 
check that this is actually a time indicator ({{procTime()}}, {{rowTime()}}) an 
that the order is ASCENDING.
* Documentation
** Add documentation for OVER windows
* Code style
** Consistent naming of {{ProcessFunctions}} and methods
* Tests
** Move the OVER window tests out of SqlITCase into a dedicated class
** Move the OVER window tests out of WindowAggregateTest into a dedicated class
** Add tests based on the test harness for all {{ProcessFunctions}} similar to 
{{BoundedProcessingOverRangeProcessFunction}}. The tests should include exact 
boundary checks for range windows and check for proper parallelization with 
multiple keys.



> Post-pass OVER windows
> ----------------------
>
>                 Key: FLINK-6257
>                 URL: https://issues.apache.org/jira/browse/FLINK-6257
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Table API & SQL
>    Affects Versions: 1.3.0
>            Reporter: Fabian Hueske
>            Priority: Critical
>
> The OVER windows have been implemented by several contributors.
> We should do a post pass over the contributed code and improve a few things.
> * Functionality
> ** Currently every time attribute is allowed as ORDER BY attribute. We must 
> check that this is actually a time indicator ({{procTime()}}, {{rowTime()}}) 
> and that the order is ASCENDING.
> * Documentation
> ** Add documentation for OVER windows
> * Code style
> ** Consistent naming of {{ProcessFunctions}} and methods
> * Tests
> ** Move the OVER window tests out of SqlITCase into a dedicated class
> ** Move the OVER window tests out of WindowAggregateTest into a dedicated 
> class
> ** Add tests based on the test harness for all {{ProcessFunctions}} similar 
> to {{BoundedProcessingOverRangeProcessFunction}}. The tests should include 
> exact boundary checks for range windows and check for proper parallelization 
> with multiple keys.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to