[ 
https://issues.apache.org/jira/browse/FLINK-17507?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

David Anderson updated FLINK-17507:
-----------------------------------
    Description: 
It would be better if fig/program_dataflow.svg used a 
{{ProcessWindowFunction}}, rather than a {{WindowFunction}}.

It also uses a {{BucketingSink}}, which sets a bad example. 

Note that this is not a trivial edit, since it doesn't work to simply replace 
{{new BucketingSink}} with {{new StreamingFileSink}}. Something like this would 
be better:

 
 {{final StreamingFileSink<GenericRecord> sink = StreamingFileSink}}
 {{        .forBulkFormat(...)}}
 {{        .build();}}

 {{stats.addSink(sink);}}

 Note: This figure is only used once, in the Training Overview page.

  was:
It would be better if fig/program_dataflow.svg used a 
{{ProcessWindowFunction}}, rather than a {{WindowFunction}}.

It also uses a {{BucketingSink}}, which sets a bad example. 

Note that this is not a trivial edit, since it doesn't work to simply replace 
{{new BucketingSink}} with {{new StreamingFileSink}}. Something like this would 
be better:

 
{{final StreamingFileSink<GenericRecord> sink = StreamingFileSink}}
{{        .forBulkFormat(...)}}
{{        .build();}}
{{}}
{{stats.addSink(sink);}}
{{}}
Note: This figure is only used once, in the Training Overview page.
{{}}


> Training figure program_dataflow.svg should use preferred parts of the API
> --------------------------------------------------------------------------
>
>                 Key: FLINK-17507
>                 URL: https://issues.apache.org/jira/browse/FLINK-17507
>             Project: Flink
>          Issue Type: Improvement
>          Components: Documentation / Training
>            Reporter: David Anderson
>            Priority: Major
>
> It would be better if fig/program_dataflow.svg used a 
> {{ProcessWindowFunction}}, rather than a {{WindowFunction}}.
> It also uses a {{BucketingSink}}, which sets a bad example. 
> Note that this is not a trivial edit, since it doesn't work to simply replace 
> {{new BucketingSink}} with {{new StreamingFileSink}}. Something like this 
> would be better:
>  
>  {{final StreamingFileSink<GenericRecord> sink = StreamingFileSink}}
>  {{        .forBulkFormat(...)}}
>  {{        .build();}}
>  {{stats.addSink(sink);}}
>  Note: This figure is only used once, in the Training Overview page.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to