[ https://issues.apache.org/jira/browse/FLINK-7509?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16143526#comment-16143526 ]
Fabian Hueske commented on FLINK-7509: -------------------------------------- Yes, with more special cases being added it might make sense to split the code for the different aggregation types: - batch group aggregation - stream non-windowed group aggregation - stream group windowed aggregation - stream over windowed aggregation But maybe another separation is more meaningful. Do you have concrete plans for the split [~jark]? > Refactorings to AggregateCodeGenerator > -------------------------------------- > > Key: FLINK-7509 > URL: https://issues.apache.org/jira/browse/FLINK-7509 > Project: Flink > Issue Type: Improvement > Components: Table API & SQL > Reporter: Jark Wu > > I think the `AggregateCodeGenerator#generateAggregations` is too long with > 500+ LOC currently and hard to extend. I would like to refactor it if you > have no objection. -- This message was sent by Atlassian JIRA (v6.4.14#64029)